Technology and Trends
 Linux Activists Mailing List Archives
  
From: ktompkin@pilot.njin.net (Ken Tompkins)
Subject: X11 Won't Return to Text Mode
Date: 4 Nov 92 12:12:16 GMT

Just to add my name to the list....I recently got
X11 working -- an Icelandic Saga in length -- and
when I exit from it the screen turns black and I
have to reboot.

Briefly my setup is:

386DX 40MhZ clone
75meg partition with 2m swap
Trident 8900c vga chipset
Most recent version of linux SLS (98.pl1)
(98.pl1)

It would be helpful if someone could solve this.

ken tompkins
stockton state college

From: dd435157@longs.LANCE.ColoState.Edu (Dan Doner)
Subject: Re: X11 Won't Return to Text Mode
Date: 6 Nov 92 19:47:29 GMT

In article <Nov.4.07.12.16.1992.20165@pilot.njin.net>, 
ktompkin@pilot.njin.net (Ken Tompkins) writes:
|> Just to add my name to the list....I recently got
|> X11 working -- an Icelandic Saga in length -- and
|> when I exit from it the screen turns black and I
|> have to reboot.
|> 
|> Briefly my setup is:
|> 
|> 386DX 40MhZ clone
|> 75meg partition with 2m swap
|> Trident 8900c vga chipset
|> Most recent version of linux SLS (98.pl1)
|> (98.pl1)
|> 
|> It would be helpful if someone could solve this.
|> 
|> ken tompkins
|> stockton state college


Same problem - similar setup.  Trident 8900c seems to be the problem.
Any solutions, anyone?

===========================================================================
/*
     Dan Doner
     Graduate Student
     Mechanical Engineering
     Colorado State University
     dd435157@LANCE.ColoState.Edu
*/

          "So much information, so few neurons..."

From: sct@dcs.ed.ac.uk (Stephen Tweedie)
Subject: Re: X11 Won't Return to Text Mode
Date: 9 Nov 92 16:59:25 GMT

In article <Nov06.194729.79509@yuma.ACNS.ColoState.EDU>, 
dd435157@longs.LANCE.ColoState.Edu (Dan Doner) writes:
> Nntp-Posting-Host: jenkins.lance.colostate.edu

> In article <Nov.4.07.12.16.1992.20165@pilot.njin.net>, 
ktompkin@pilot.njin.net (Ken Tompkins) writes:
> |> Just to add my name to the list....I recently got
> |> X11 working -- an Icelandic Saga in length -- and
> |> when I exit from it the screen turns black and I
> |> have to reboot.
...
> Same problem - similar setup.  Trident 8900c seems to be the problem.
> Any solutions, anyone?

Add me to the list - only with a Tseng ET400 Hicolor (unbranded "vga
ultra") card.  Returning to 80x25 text mode works but corrupts several
font characters; returning to any other text mode doesn't restore
timings correctly resulting in unreadable flicker (my monitor has
fixed frequencies and cannot synch to the mode left by X11).

Btw, my old graphics card - a Trident 8900c v4 - restored text
perfectly (although X was unable to program interlace correctly on the
older version of the chipset, so I couldn't use the 1024x768 mode).
So it's not a problem with the X setup (X11v1.1 running under 0.97pl6,
for what it's worth).

Oh, one other thing. The only reason I was ever using text mode was to
see kernel printk messages, so I hacked together a 10 line syslogd to
pipe them to /dev/console for xconsole to display - works fine.  I
know HJ has incorporated the syslog.c logging functions into libc4.2,
but does anyone know whether there is a proper (official?) syslogd
linux port anywhere?  I've got the bsd source but there's no point in
reinventing the wheel if there is already a standard Linux version out
there in netland.

Thanks,
 Stephen Tweedie.
---
Stephen Tweedie <sct@uk.ac.ed.dcs>   (Internet: <sct@dcs.ed.ac.uk>)
Department of Computer Science, Edinburgh University, Scotland.