Tech Insider					     Technology and Trends


			      USENET Archives

From: r...@aladin.stgt.schwaben.de (Klaus Herrmann)
Subject: ibcs2 does not compile with kernel 1.3.10
Date: 1995/07/19
Message-ID: <DByMzA.By@aladin.stgt.schwaben.de>#1/1
X-Deja-AN: 106437355
organization: Private Linux Site
keywords: ibcs2, kernel 1.3.10
newsgroups: comp.os.linux.development.system

Hi netters,

iBCS2 does not compile with kernel version 1.3.10. I got the following
compiler error messages (GCC 2.6.3) when comliling coff.c. There are other
errors by doing a 'make -k', but they lead into the same direction.

Is anybody still working on iBCS ?

Thanks in advance

Klaus Herrmann



-------------- stuff deleted ------------------

set -e; for i in iBCSemul x286emul Tools; do \
  test ! -d $i || \
    { make  -C $i; }; done
make[1]: Entering directory `/export/usr/src/ibcs/iBCSemul'
cc -D__KERNEL__=1 -DMODULE -I../include -Wall -Wstrict-prototypes -O2 
-fomit-frame-pointer -m486 -DSOCKSYS_MAJOR=30  -DEMU_SCO -DEMU_ISC 
-DEMU_SVR4 -DEMU_BSD -DEMU_WYSE -DEMU_WYSEMP -DEMU_X286 -DEMU_XTI 
-DEMU_BINFMT_COFF -DEMU_BINFMT_XOUT -DIBCS_TRACE -DVERBOSE_ERRORS 
-DCOFF_TRACE -DXOUT_DEBUG -c emulate.c
In file included from emulate.c:57:
../include/ibcs/ibcs.h:32: warning: function declaration isn't a prototype
cc -D__KERNEL__=1 -DMODULE -I../include -Wall -Wstrict-prototypes -O2 
-fomit-frame-pointer -m486 -DSOCKSYS_MAJOR=30  -DEMU_SCO -DEMU_ISC 
-DEMU_SVR4 -DEMU_BSD -DEMU_WYSE -DEMU_WYSEMP -DEMU_X286 -DEMU_XTI 
-DEMU_BINFMT_COFF -DEMU_BINFMT_XOUT -DIBCS_TRACE -DVERBOSE_ERRORS 
-DCOFF_TRACE -DXOUT_DEBUG -c map.c
cc -D__KERNEL__=1 -DMODULE -I../include -Wall -Wstrict-prototypes -O2 
-fomit-frame-pointer -m486 -DSOCKSYS_MAJOR=30  -DEMU_SCO -DEMU_ISC 
-DEMU_SVR4 -DEMU_BSD -DEMU_WYSE -DEMU_WYSEMP -DEMU_X286 -DEMU_XTI 
-DEMU_BINFMT_COFF -DEMU_BINFMT_XOUT -DIBCS_TRACE -DVERBOSE_ERRORS 
-DCOFF_TRACE -DXOUT_DEBUG -c coff.c
In file included from coff.c:40:
../include/ibcs/ibcs.h:32: warning: function declaration isn't a prototype
coff.c: In function `ibcs_exec':
coff.c:163: warning: `p' might be used uninitialized in this function
coff.c: In function `ibcs_read':
coff.c:247: sizeof applied to an incomplete type
coff.c:270: dereferencing pointer to incomplete type
coff.c:276: dereferencing pointer to incomplete type
coff.c:279: dereferencing pointer to incomplete type
coff.c:285: dereferencing pointer to incomplete type
coff.c:291: dereferencing pointer to incomplete type
coff.c:294: dereferencing pointer to incomplete type
coff.c:296: dereferencing pointer to incomplete type
coff.c:296: dereferencing pointer to incomplete type
coff.c:296: dereferencing pointer to incomplete type
coff.c:301: dereferencing pointer to incomplete type
coff.c:301: dereferencing pointer to incomplete type
coff.c:302: dereferencing pointer to incomplete type
make[1]: *** [coff.o] Error 1
make[1]: Leaving directory `/export/usr/src/ibcs/iBCSemul'
make: *** [all] Error 2

-----------------------------------------------------------------
-- 
*******************************************************************
Klaus Herrmann                |      
73760 Ostfildern 	      |      kl...@aladin.stgt.schwaben.de
Germany

From: Mike Jagdis <ja...@purplet.demon.co.uk>
Subject: ibcs2 does not compile with kernel 1.3.10
Date: 1995/07/19
Message-ID: <878.300ED4D6@purplet.demon.co.uk>#1/1
X-Deja-AN: 106594015
x-nntp-posting-host: purplet.demon.co.uk
sender: "newsout1.26" <ufg...@purplet.demon.co.uk>
organization: FidoNet node 2:252/305 - The Purple Tentacle, Reading
newsgroups: comp.os.linux.development.system

* In message <DByMzA...@aladin.stgt.schwaben.de>, Klaus Herrmann said:

KH> iBCS2 does not compile with kernel version 1.3.10. I got the
KH> following
KH> compiler error messages (GCC 2.6.3) when comliling coff.c.
KH> There are other
KH> errors by doing a 'make -k', but they lead into the same
KH> direction.

KH> Is anybody still working on iBCS ?

Yes. Basic changes to get it to compile against 1.3 shouldn't be beyond 
anyone with a basic knowledge of C if you really must. If you don't know C 
or don't have the time to hack a few lines of code then I have to question 
whether you are wise playing with the latest 1.3 kernel.

  There will be a new release when *I* find enough time to hack the code.

                                Mike  

From: Fred Broce <fbr...@atlanta.com>
Subject: Re: ibcs2 does not compile with kernel 1.3.10
Date: 1995/07/19
Message-ID: <3uk07l$54c@nntp.atlanta.com>#1/1
X-Deja-AN: 106594020
references: <DByMzA.By@aladin.stgt.schwaben.de>
content-type: text/plain; charset=us-ascii
organization: Internet Atlanta
x-url: news:DByMzA.By@aladin.stgt.schwaben.de
mime-version: 1.0
newsgroups: comp.os.linux.development.system
x-mailer: Mozilla 1.1N (X11; I; Linux 1.3.11 i486)

There is a patch to both ibcs and the kernel that I have gotten to work with
kernels as late as 1.3.10..I too wonder if development has stopped. I have had
mixed results patching the kernels..sometimes they will compile and sometimes
you have to repatch it and try again.  My guess is the patch is not applied the
same in every case..the patch is labeled for 1.3.4..as I said I have gotten it
to work as late as 1.3.10..

Here is where is is:ftp://ftp.premier.net/pub/linux/ibcs2

fbroce

From: Mike Jagdis <ja...@purplet.demon.co.uk>
Subject: Re: ibcs2 does not compile with kernel 1.3.10
Date: 1995/07/20
Message-ID: <879.30101EE6@purplet.demon.co.uk>#1/1
X-Deja-AN: 106593960
x-nntp-posting-host: purplet.demon.co.uk
sender: "newsout1.26" <ufg...@purplet.demon.co.uk>
organization: FidoNet node 2:252/305 - The Purple Tentacle, Reading
newsgroups: comp.os.linux.development.system

* In message <3uk07l$...@nntp.atlanta.com>, Fred Broce said:

FB> I too wonder if development has stopped.

No, it hasn't stopped. But I can count the number of patches sent in in the 
last year on the fingers of one hand. None of them relate to 1.3 either :-).

                                Mike  

From: Fred Broce <fbr...@atlanta.com>
Subject: Re: ibcs2 does not compile with kernel 1.3.10
Date: 1995/07/21
Message-ID: <3unvl7$2op@nntp.atlanta.com>#1/1
X-Deja-AN: 106711481
references: <878.300ED4D6@purplet.demon.co.uk>
content-type: text/plain; charset=us-ascii
organization: Internet Atlanta
x-url: news:878.300ED4D6@purplet.demon.co.uk
mime-version: 1.0
newsgroups: comp.os.linux.development.system
x-mailer: Mozilla 1.1N (X11; I; Linux 1.3.11 i486)

There is one patch out there that will work..

Look at :

ftp://ftp.premier.net/pub/linux/ibcs2/

The patch for both ibcs and the kernel is labeled for 1.3.4..I have gotten it
to work with 1.3.10..

Glad to know new support is on the way!!

Fred

From: sz...@ccc.amdahl.com (Sid Boyce)
Subject: Re: ibcs2 does not compile with kernel 1.3.10
Date: 1995/07/22
Message-ID: <1995Jul22.061952.26478@ccc.amdahl.com>#1/1
X-Deja-AN: 106711494
distribution: ww
references: <878.300ED4D6@purplet.demon.co.uk> <3unvl7$2op@nntp.atlanta.com>
organization: Amdahl Corporation, Sunnyvale CA
keywords: ibcs2 coff
reply-to: sz...@JUTS.ccc.amdahl.com (Sid Boyce)
newsgroups: comp.os.linux.development.system

In article <3unvl7$...@nntp.atlanta.com> Fred Broce <fbr...@atlanta.com> writes:
>Content-Transfer-Encoding: 7bit
>X-Mailer: Mozilla 1.1N (X11; I; Linux 1.3.11 i486)
>X-URL: news:878.300ED4D6@purplet.demon.co.uk
>
>There is one patch out there that will work..
>
>Look at :
>
>ftp://ftp.premier.net/pub/linux/ibcs2/
>
>The patch for both ibcs and the kernel is labeled for 1.3.4..I have gotten it
>to work with 1.3.10..
>
>Glad to know new support is on the way!!
>
>Fred
>
   I have had no trouble compiling it and have tried with up to 1.3.8
but I get a message saying "wrong version of do_signal" when trying
insmod, I think I am using something like 1.2.8 version of modules
with the ELF changes. Have had a brief look at do_signal.c, but so
far haven't been able to pin down the trouble, any ideas ???
Regards
Sid...G3VBV...Amdahl(UK)...

From: Mike Jagdis <ja...@purplet.demon.co.uk>
Subject: Re: ibcs2 does not compile with kernel 1.3.10
Date: 1995/07/23
Message-ID: <880.3012CC09@purplet.demon.co.uk>#1/1
X-Deja-AN: 106772845
x-nntp-posting-host: purplet.demon.co.uk
sender: "newsout1.26" <ufg...@purplet.demon.co.uk>
organization: FidoNet node 2:252/305 - The Purple Tentacle, Reading
newsgroups: comp.os.linux.development.system

* In message <1995Jul22.061952.26...@ccc.amdahl.com>, Sid Boyce said:

SB> I have had no trouble compiling it and have tried with up to 1.3.8
SB> but I get a message saying "wrong version of do_signal" when trying
SB> insmod, I think I am using something like 1.2.8 version of modules
SB> with the ELF changes. Have had a brief look at do_signal.c, but so
SB> far haven't been able to pin down the trouble, any ideas ???

If you think you have compiled against 1.3.8 it can only be because you 
omitted to do a "make clean" first.

  I've put a new version of iBCS on tsx-11.

                                Mike

			        About USENET

USENET (Users’ Network) was a bulletin board shared among many computer
systems around the world. USENET was a logical network, sitting on top
of several physical networks, among them UUCP, BLICN, BERKNET, X.25, and
the ARPANET. Sites on USENET included many universities, private companies
and research organizations. See USENET Archives.

		       SCO Files Lawsuit Against IBM

March 7, 2003 - The SCO Group filed legal action against IBM in the State 
Court of Utah for trade secrets misappropriation, tortious interference, 
unfair competition and breach of contract. The complaint alleges that IBM 
made concentrated efforts to improperly destroy the economic value of 
UNIX, particularly UNIX on Intel, to benefit IBM's Linux services 
business. See SCO vs IBM.

The materials and information included in this website may only be used
for purposes such as criticism, review, private study, scholarship, or
research.

Electronic mail:			       WorldWideWeb:
   tech-insider@outlook.com			  http://tech-insider.org/