Technology and Trends
 Video for Linux Mailing List Archives
  
To: video4linux-list@xxxxxxxxxx 
Subject: v4l / v4l2 -- install and bugs? 
From: James Green <jg@xxxxxxxxxxxxxxxxxxxxxx> 
Date: 25 Sep 2001 23:43:03 +0100 
Delivered-to: video4linux-list@xxxxxxxxxxxxxxxxxx 

Hi all,

I have some questions about dealing with, well, the "world" to get my tv
card to work.

The card is a bttv878. I have an nvidia GeForce IIMX (AGP) graphics card
and use nvidia's own 'NVdriver' XFree86 module.

Now, I've found immense confusion on the net concerning what to get from
who, and what it will provide.

I'm advised by the authors of 'zapping' (cool tv app,
zapping.sourceforge.net) that "everything should work" when you use v4l2
and bttv2.

I've been to http://bttv-v4l2.sourceforge.net and found some stuff
there, and also to http://www.thedirks.org/v4l2/ with more stuff. I
gather that the latter is maintaining the videodevX stuff, whilst the
former is maintaining the driver (bttv2)?

One major problem I have had in running these is that as soon as I open
zapping, I get 50% or so cpu usage. I'm told that this is due to a bug
somewhere stopping, er, something from using the nvidia card's hardware
scaler. Any ideas who to prod about this?

This problem also affects the ability to open the tv window up to more
than 640x480, and also fullscreen. Indeed, under v4l2 fullscreen is
actually a 640x480 image with black border around it, with only the
leftmost 20% moving, the rest is corrupt.

I've just put 'Load "v4l"' back into my XFree86 4.1 config file and now
zapping opens with practically no cpu uasge, however clearly it cannot
use hardware scaling.

It would appear that if I want fullscreen, I use v4l2 and accept the
640x480 screen res drop, or use v4l1 and accept that I cannot use
hardware scaling. Oh, and I cannot take screen captures without it going
into a high-cpu low-framerate mode.

So, does anyone know what the current situation on this lot is, what I
should be using, and who to prod to get what to work?

Also, if I compile and install videodeX from thedirks.org, am I supposed
to remove the 'Load "v2l"' line from the XFree86 config file? The
webpage doesn't make any mention of it...

Many thanks,

James Green

To: video4linux-list@xxxxxxxxxx 
Subject: Re: v4l / v4l2 -- install and bugs? 
From: Alan Cox < alan@xxxxxxxxxx> 
Date: Wed, 26 Sep 2001 11:55:30 -0400 (EDT) 
Delivered-to: video4linux-list@xxxxxxxxxxxxxxxxxx 
In-reply-to: < 1001457784.26893.13.camel@cyberstorm> 
from "James Green" at Sep 25, 2001 11:43:03 PM 

> One major problem I have had in running these is that as soon as I open
> zapping, I get 50% or so cpu usage. I'm told that this is due to a bug
> somewhere stopping, er, something from using the nvidia card's hardware
> scaler. Any ideas who to prod about this?

Its a binary only module. Take it up with nvidia, nobody else can help you